Back to overview
Downtime

Jobs Unable to Process

Feb 07 at 03:15am PST
Affected services
Job Processing

Resolved
Feb 07 at 04:19am PST

Root Cause Analysis (RCA)

Incident Summary:
On [date/time of the incident], our services experienced a disruption due to a database service undergoing automatic maintenance. This maintenance reset the DNS configuration, causing our systems to lose connection to the database. The issue persisted because the affected services did not reestablish the connection properly.

Additionally, certain users experienced degraded performance for approximately 3 hours following the incident. These users had concurrency limits in place and continued pushing jobs at their normal throughput levels. Due to the disruption, a backlog of jobs built up, and our systems did not automatically increase their concurrency limits to help process the queue more efficiently.

Resolution:
Our team quickly identified the root cause of the database connection issue, restored service functionality, and worked to process the backlog of jobs.

Preventative Actions:
To prevent similar incidents in the future:

We are transitioning automated maintenance windows for critical database services to manual scheduling to minimize unexpected changes.
We are enhancing our internal service mechanisms to better handle connection reestablishment in the event of similar disruptions.
We are implementing improvements to automatically adjust concurrency limits during recovery periods to ensure backlogs are cleared more quickly.
We sincerely apologize for the inconvenience caused and appreciate your understanding as we take these steps to ensure greater reliability and performance. If you have further questions or concerns, please don't hesitate to reach out to our support team.

Thank you for your continued trust.

Created
Feb 07 at 03:15am PST

Our job processing and monitoring infrastructure is down, we are working on resolving it urgently.